Jump to content

DLN:Inspector version 1.0 Beta

Recommended Posts

Trying to use DLN:Inspector with a DLN database (the sample database which installs with DLN:CC).

The 'Project' at the top of the DLN:Inspector GUI does allow you to select a project; but the drop-down 'Group' to select image groups drop-down/combo is always empty so cannot get any further. Same if run DLN:Inspector RTI or PG. The DLN database has both the LACMA tests (RTI and PG) and some of my own initial tests in as well. None of them are accessible from DLN:Inspector

(also, unlike DLN:CC, there's no 'About' which allows one to report more detailed version/build info, only the 'Version 1.0 Beta' in the title bar of the application)

Capture 6.PNG

Link to comment
Share on other sites

Thanks for the feedback Dave.  Here are a couple of notes:

1.  You can run inspector without the database from DLNCC - and that might be the easiest way to use it when you are just getting started.  This is also great for checking your own legacy data, that isn't in the DLNCC tool.  If you want to do this you can turn off using the DLN in the "options" pane.  You can turn it back on any time you like.


2.  If you want to use it with the sample data, you will need to change the path for the sample data to wherever you installed it on your hard drive.  I should have included that in the README for the sample data - sorry about that.  If you use Inspector with DLNCC - it assumes it can find the files and folders in the stored path for the project.  So, update the path at the project level, and keep the sample files under that and it should work.


Thanks for taking the time to try out the tools!  I think you will find the Inspector reports really useful, once you get over these early hiccups.



Link to comment
Share on other sites

  • 2 years later...

Hi Carla,

I've set up a project, image set group, and a single RTI image set for initial testing using the DLN-CC tool.  I then tried to inspect the image set using the DLN-Inspector tool, after updating the DLN database according to instructions in Appendix A1 of the User Guide DLN Inspector.  When I opened the DLN Inspector, it shows me the Project Name in the first drop-down selection box, but it doesn't show any Image Groups in the second drop-down selection box.  I've tried quitting and opening both the DLN-CC tool and the DLN-Inspector tools, but this doesn't make a difference.  I've tried checking all my entries in the DLN-CC tool, but I can't find anything wrong.  Do you have any suggestions for what else I should be checking? 

Other items:

  • I found a couple of typos in the Appendix A.1.1 of the User Guide, DLN Inspector.  In step 7, it states,

    "Use the cd command to change to the scripts subfolder. For example, to go to the folder in step 2, type the command:
    cd /Applications/DLN-Inspector-PG.app/Contents/MacOS

    This appears to refer to Step 3 rather than Step 2, and there isn't a scripts subfolder in the directory (Step 4 also refers to the scripts subfolder, which doesn't exist).
  • Using DLN-CC, when I use the button "Save RDF" in the Image Sets Overview window, I get a series of java errors that says the following:

    Some error occured: The transformer didn't save anything in the ouput RDF file..


    Transformer's output:


    Exception in thread "main" java.lang.UnsupportedClassVersionError: eu/delving/x3ml/X3MLCommandLine : Unsupported major.minor version 51.0

    at java.lang.ClassLoader.defineClass1(Native Method)

    at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)

    at java.lang.ClassLoader.defineClass(ClassLoader.java:621)

    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

    at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

    at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

    at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

    at java.security.AccessController.doPrivileged(Native Method)

    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)


    However, I checked the directory for the image set and it does contain a new file named "dln-cptset.xml" that appears to contain all the relevant information for the image set.

Best wishes,


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...