Jump to content

DLN:CC on MAC Arm-chips with Postgres 14 (or others?)


Recommended Posts

Hey there,

i am currently trying to get everything running on a Macbook with M1Max chip. Therefore, i am running the Postgres.app with PostgreSQL 14 (Universal).

Neither CLN:CC nor the Inspector-Apps are working. In all cases, i receive a "Driver not loaded" error.

 

I tried older versions of Postgres (including the one that comes with the DLN:CC-installation, Postgres var. 9.6), all of them generate the same error.

Am i missing something? Has anyone had the same issue with the new Mac-chips? I haven't used DLN:CC in quite a while but remember it worked flawlessly on my older Macbook (Intel chip) .

I have attached some pictures of the error messages down below. Nothing special with them. As far as i understand: Postgres is running stable, but for some reason DLN:CC cannot connect. 

 

Kindest regards,

Nils

Bildschirmfoto 2022-04-05 um 16.51.59.png

Bildschirmfoto 2022-04-05 um 16.52.06.png

Bildschirmfoto 2022-04-05 um 16.52.21.png

Bildschirmfoto 2022-04-05 um 16.57.48.png

Link to comment
Share on other sites

Hi Nils -

 

We have been working to get the 1.0 release completed, and we have a release candidate now (RC4 actually) .  We found an issue with the Mac installaer that is being worked on - but I'd like to have you try the new software as soon as we have that.

We do not yet have a Mac with an M1 chip - though we have one on order that should be here later this month.  It would be super helpful to have this checked out.

We did upgrade the Postgres DB - but I don't remember what number we are on now.

There are massive improvements and new features, including that the Inspector is fully integrated, there's a working archiver tool, we can collect info about processing and results (called work products)  So, I'll let you know when there is a version you can try.  I am hoping this week.

Carla

Link to comment
Share on other sites

We've had a bit of a delay with the Mac installer - related to getting it signed in the Apple Developer program.  We hope to have something to try out in the coming days. 

We have been using Postgres 13.3 - but the developers have also tested on 14.2 with no problems.  

In the new software we install our own private copy of Postgres so as not to interfere with any databases someone might have installed or running on their system. We use a non-standard port number to communicate with it. 

Carla

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...

Hello and thanks for checking back.  We ran into some issues getting the installer through the Apple process  - and we had to change how we were packaging Postgres.  The good news is that I now have a version that you can use.  It has a proper installer and Apple Developer certificate!

I now have access to a Mac with M1 hardware - and I have tried it there and it installs and works.  The software is designed to run on MacOS 10.13.x High Sierra and later.

This is our Release Candidate 5 (yes I know - it's always something - this is why it's taken us a while to get the release completed) 

https://www.dropbox.com/sh/ahwh3gi34r1sn62/AADXRvGhxbivS_cDvUq1kJFJa?dl=0

In this dropbox you will find both the Mac and Windows installers along with a draft User guide - that is fairly complete - but needs a bit more work.  We are collecting ideas for an update release, and at this point will only be fixing showstopper bugs.  We are happy to have more eyes on the software and more feedback.  Anyone else reading this - we would appreciate it if you drop a note on this thread and let us know that you are trying out the software - even if you don't have anything to report. Tell us what platform you are on.

There is sample data installed with the database. There is still a little work to finalize it. You can also backup and restore data you may have created from the Beta version.  You do that using Restore in the database menu in the software - and it will run scripts to update your database to match the latest data model.  There are a lot of new features - that you will not have any data for - but you can at least reuse your equipment, locations, subjects etc.  You might want to play with the sample data before restoring your own data - as it is fairly complete with examples of processing, work products, and SIPs.  Also - review the section of the user guide about backup and restore.

If you want to use image data that goes with the sample data - you can get that from this dropbox (not quite final)

https://www.dropbox.com/sh/z3mnalr29z3bu8a/AACYrcTjH1_uHi7tKC0kPhi4a?dl=0

When we release to our website - we will have zip files containing the sample data for folks to download.

Thank you for your interest - and for trying out the software.

Carla

 

Link to comment
Share on other sites

Dear Carla,

thanks, that sounds like great news both for you and the team at CHI as well as for us users - i can't wait to get my hands on it.

Unfortunately, i am still not able to get it running. The .pkg works as expected until i reach the last step where the installation should start. Then, all that happens is that i get an error message, which says something like: "Installation failed. Please contact the developers" (See screenshot below, it is in german though)

I am Running MacOS Monterey 12.3.1, which is the latest MacOS version. I cannot downgrade my MacOS version. I tried both with an already installed Postgres and deinstalling everything before installing your .pkg. Even though you have the license, i changed my installation-settings to allow anything being installed, even without certificate (Allow apps from "Anywhere"), that didn't help either.

Really weird. I am running out of ideas. Anyone else having the same issue? Any ideas so far? What else can i try?

 

 

 

 

Bildschirmfoto 2022-05-16 um 13.58.35.png

Link to comment
Share on other sites

Hi Nils -  My mistake - I put a slightly older version of the software into the dropbox right before leaving for a conference - bringing a different laptop. I'm back home and I have now replaced the Mac one in the dropbox with the correct one.  We ran into the same security issue - and it was fixed.

I'm sorry about this - I was running to get ready for my trip.

Please try the new one on your Mac - it has -2 at the end.  I have it installed on an M1 architecture Mac - so hopefully it works for you.

Dave - I'll look into the Windows one - I haven't had any problems with the installer there in a long time.

Carla

Link to comment
Share on other sites

  • 1 month later...

Hello, Everyone. 

I have a Mac M1 running Monterey and so far the DLN appears to be running smoothly. I will keep you posted if I come across any bugs in my travels. I will be using this program to collect data for my PhD research and a coin project that I am working on at the Athenian Agora. 

That said, @cdschroer can I contact you directly about gaining access to the source code for the RTI Builder and Viewer. I know your team has been extremely busy and I would like to help in developing a more compatible version for the Mac M1. I have the programs running through Crossover and is working well thus far. However, I do have some high end developer contacts that could help with updating these programs. I have mentioned my project to them and they want to help when they can. Most likely at no cost to CHI. They are big supporters of open source.

Thank you everyone for the great advice and community on these forums.

Link to comment
Share on other sites

Thank you for the update.  We have the final release software now, and are getting it setup for download on our website.  There are proper installation guides now , as well as a final User Guide.  Please note that when you install the final release on Windows - you should uncheck the box for installing postgres, if you have been trying one of the pre-release versions.  For Mac users, this is all handled for you automatically by the installer.  This is described in the guide.  We hope to push the pages today - and do announcements over the coming week or two.

 

Regarding RTiBuilder - it will be replaced by RelightLab from the Visual Computing Lab in Pisa - 

RelightLab will replace RTIBuilder.  We do not have dates for a final release - where our team will provide documentation and examples and additional features will be added to the tool, as well as having properly signed code. We just received some grant funds to help with this and we are working on an agreement and schedule now.  The current tool (version 1.2.3) does work and can build HSH based RTIs in the .rti format- and also a new format called "relight" developed by the VCL team - specifically for web distribution.  The new format runs in the OpenLIME viewer.  PTM format is not currently implemented - though it is in the menu.

 

I'll be posting more to the Processing RTI forum shortly.  Trying to finish getting DLN out right now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...