Jump to content

ptm fitter - unknown file format: .JPG


Recommended Posts

Hey! I have problems during the execution of the builder with the PTM Fitter. It start cropping images but at the end appears the "unknow error" message, and in the upper right of the windows the message is "unlnow file format: .JPG". I've tried changing the extensions in .jpg (downsizing) and in .jpeg (maybe the program can only read .jpeg..), but nothing change. Every time I've made I change I started a new project, just to be sure I did not commit any error.

With the HSH Fitter everything is okay! 

P.s. When I tried upload the folder with the "jpeg-exports" the builder do not start uploading images and he glitch the hourglass. I had to brutally close the program. I tried many times many combinations but nothing. 

Link to comment
Share on other sites

(This thread would really be better in the 'RTI Processing' section, maybe one of the Admins could move it?)

Hi Alessandro,

A couple of questions, then a suggestion.

1) Have you ever built successfully using PTM?
2) Can you advise what operating system and version you're running?
3) Can you advise size and source of your images?

To identify if it is a problem with your images or with the installation on your computer, could I suggest you try using one of the sample image sets which CHI provide, as they are known to work.


Please forgive me if these duplicate what you know or have tried, but this is the simplest set of steps, could you try these as they definitely work (below are written for a Windows operating system).



  1. On your PC, if you don’t already have one, make a folder RTI at the top level on your C: drive, and within that, make a folder Fish_1000 so you end up with C:\RTI\Fish_1000

  2. Download the Fish_1000 set of example files from http://culturalheritageimaging.org/What_We_Offer/Downloads/Process/
    And then – somewhere else on your PC - expand the fish_fossil-data-set_1000.zip file. In the zip file, down one level, you will see a folder jpeg-exports      Copy that folder and its contents into C:\RTI\Fish_1000 so you end up with C:\RTI\Fish_1000\jpeg-exports which will contain 36 photographs named fish_fossil_01.jpg through fish_fossil_36.jpg


  3. Start RTI Builder

    In the Project Name box, type Fish_1000_PTM
    In the Operation Sequence block, click on the first option – Highlight based (PTM Fitter)
    Then click the [Start new project] button


  4. On the Image selection screen which opens with an initial blank list, click the [Open folder] button at the right-hand edge of the screen

    In the Windows selection box which pops-up, it usually seems to default browsing to ‘My Documents’.
    Click on the ‘Computer’ icon (fourth one down) in the left-hand bar
    Double-click on C:
    Double-click on the RTI folder
    Double-click on the Fish_1000 folder
    Then click [Open]   (N.B. please don’t click on the ‘jpeg-exports’ folder)

    You should then see a pop-up ‘Loading images’ with a progress bar
    When all the images have loaded, you should then see 36 images in the selection pane
    after which you should be able to proceed with RTI processing; and as you proceed with building your RTI model, you should see an xml and other folders appear in the project folder, so eventually, if you just proceed (using default options and not cropping) you will have:
    and your finished model will be
    C:\RTI\Fish_1000\finished-files\ Fish_1000_PTM_1000.ptm



Link to comment
Share on other sites

Thank you Dave!

I've already tried using the Fish Fossil files provided by CHI and it works fine with that (also the visualization with the rti-reader). 

When I try with my images it doesn't work: with the "manually changed" .jpg to .jpeg the open folder button crash (glitch, meaning it doesn't work; it doesn't upload the images). With the initial .jpg files I use (I do not work with .raw, and that should be another question, but not now..) the folder charge, than ball detection, highlight detection, than also cropping but it stops during executing, showing me that unknown error (unknow file format: .JPG, in the right side of the window). When using .jpg files, it load my images, ball detection, highlight detection, executing, it stop with the error, but it creates the assembly folder (with inside two .lp files and three .jpg files), it also create a .xml file in my folder.

So I can't understand why this happens.

1- I've never succesful created a ptm, (only the fish fossil with the files already provided)

 2- I'm running Windows 10 Home (x64), with 8gb Ram and a i5 processor.

3- The size of my pictures is 4608x3072 (rti-builder final step) but I also tried resing it to 3000x2000. What do you mean for "source"?




Link to comment
Share on other sites

Hi Alessandro,

Thanks for that information.

By 'source' for the images I meant what camera and what type of file are you capturing (ARW, RAW, DNG, TIF etc.) and resolution; and any processing you're doing before attempting to make the RTI PTM.

If you are able to share, if you could upload two folders (i) the files directly from the camera, and (ii) whatever you're trying process, to DropBox or similar, then I'd be glad to have a look and try to build PTM on my own workstations (will be a few days before I would have time though).


Link to comment
Share on other sites

  • 4 weeks later...

I ran into the same problem as Alessandro. HSH...no problem. PTM gave me an error at the final processing stage. Images were taken with a Nikon D800 at 7360 X 4912 pixels (36mp).Processing was done under Windows 10 with 64gb of memory.

Per Dave’s recommended procedure above, I set up a fresh download of builder and the fitter on the C Drive. Pulled in the fish fossil sample set...that processed no problem. I then took my file set reduced the image size to match the fish fossil test set (2000 pixels on the long edge). Worked fine. So I started increasing the file size.

To make a long story short, I ended up, removing the metadata, processing the full file size image, and then cropping the image at the end. I was able to successfully perform a PTM run with an image file cropped up to 29.19 megapixels. If I cropped to 29.21 megapixels or more it would fail, so it appears that there is a size limit on the PTM processor.

Alessandro is working with a much smaller image size but only 8gb of memory , but I would think that that should be enough. I would recommend removing the metadata from the files, and then testing. Not sure what effect that will have but it seemed to make my files process more smoothly. Try different cropped sizes and see how far you can go before it fails. You can then size your images accordingly.

I read a comment by Carla in another post that indicated that apple computers don't seem to have a problem. An associate of mine is going to try and see what happens.

Hope this helps


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...