Jump to content

Unknown Error Detected


Recommended Posts

dear all,


our RTI builder does not always work with high-resolution jpgs...

In 1 from 30 trys we can built a PTM-file with high-resolution jpgs (8688x5792; approx. 12 MB) successfully, but in most of the cases it does not work and we get the message: Unknown Error Detected. 

Unable to open file D:\03_RTI-OeAI_2019\Master\003\raw-jpg_010\cropped-files\000361.jpg


In the attachment you find the screenshot  



Sometimes it works and sometimes it doesn't - we have no idea why!

We need the PTM-file with the high-resolution jpgs and we hope, somebody can solve this problem.


Thank you in advance, 

Niki and Judith

Austrian Archaeological Institute Vienna


Link to comment
Share on other sites

Can you say more about the computer you are using and it's specs.  For Example Mac book pro with 16GB RAM and MacOS 10.12.6

Also - you can look in the .xml log file that RTI Builder produces, which will sometimes give you a clue as to what is going on. In this case- from the screen shot it appears that RTiBuilder is successfully making all of your cropped files, and the failure happens within the PTMFitter.  

The fact that the PTMfitter can't open the file, might indicate a permissions problem.  Where did you instal the ptmfitter?

Are you able to build HSH based RTIs? the HSHfitter is included with RTIBuilder, so it should just work, without installing extra software.

One other thing to try is to make smaller jpegs and see if it works - We regularly make RTIs of this size or larger, but we have fairly "beefy" machines with a lot of RAM (16GB - 128GB)


PS: If you don't know what the "fitters" are - you might want to check out the Glossary: http://culturalheritageimaging.org/What_We_Offer/Downloads/Capture/CHI-RTI-Glossary_v1.pdf

Link to comment
Share on other sites

dear carla,

thanx a lot!!!

HP Z440 workstation

Intel (R) Xeon (R) CPU E5-1620 v4 @ 3,50 GHz 3.50 GHz

48,0 GB Ram

64 Bit System x64 based Processor

harddisc space more than 1 TB

the PTMfitter is in that directory: C:\RTIbuilder_v2_0_2\PTMFitter

cropping is not started...

no outher programms are running during processing RTI data

attached our last xml file.

what can we do?


all the best


niki and judith


Link to comment
Share on other sites

Niki/Judith, a couple of thoughts:

1) to try and find out if it is something with the images, or with, say, memory, it would be worth as Carla says trying a down-sampled set of the same images just as a test; maybe resample them down to half their size (you can use the free IrfanView to do this in batch mode).

2) also, if you have a smaller number of the big images, does it crash the same?

3) does it always stop on 000361.jpg  ?

4) the folder named says ....\cropped\... - are all the images the same size after cropping? - is there any chance the offending one is a different size?

5) is it the same if you try on a different computer?


Link to comment
Share on other sites

Thanks Dave  - good suggestions!

I'll add that the xml file indicates the error is in ptmfitter:

DATEF="" DATES="" LEVEL="WARNING" USER="">Fitter returned an error ! Error : -1</xc:event>

We see that in the screenshot as well, that ptmfitter is not able to open the file. So, try building an RTI with the hshfitter and see if that works.  You have plenty of memory on your computer, and we build files this size with a less beefy machine.  However there have been some issues with large files with the ptmfitter on Windows that don't occur on Mac.  Also, are you rotating the images before you put them in RTiBuilder?  In other words, are the images landscape or portrait, and are they all the same?  They really need to be all the same.

Hope this helps.



Link to comment
Share on other sites

Dear Carla and Dave,


Thank you both sooo much!!!!


All of the images are the same,

we have the newest version of Java,

we deinstalled the RTI software and then installed it again,

by the way, the PTM fitter from HP labs is not available anymore, so we couldn’t make a new download and had to use the one we already had on our computer,

then we restarted the computers before the processing:


We tried the same images on three different computers (all Windows) and we got three different results:

1.       We got “Fitting completed” but there was no file…

2.       The cropping started but we got the “unable to open file” on image number 33 of 40.

3.       The cropping started with the error “unable to open file” on image number 2 of 40.


To point 2 is to add: We tried the process with the 32 images, and on the same computer one time it worked and one time it didn’t work. (but we need all images)


 During the process we get the folders:

-          assembly files: blend 1, cropped.lp, edge0.jpg, median0-jpg, originalset.lp

-          cropped files: empty

-          finished files: empty


 When we try the HSH fitter we get a “Jpeg Library Error”.


We explain you the process how we get our jpgs:

-          We take our pictures with a CANON 5D SR in RAW.

-          Then we make corrections on the raw-files (make them brighter, darker, change white-balance, etc.) and we rotate the raw-files, if necessary, and convert them into tiffs.

-          Finally we convert the tiff-files into jpg-files with ACDSee Professional 2019. For testing we used different jpg-quality options between 69% and 100%, image size between 6,5 MB to 35 MB.


With this process we got perfect results some weeks and months ago, but now most of the time it doesn’t work.


– It works with really small jpgs – but we cannot use the small images, it has to work with the original ones.

The original image have the size of 8688x5792 pixel.


Now we made several tests with different sizes and amounts of images:


Our last test with smaller jpgs (5000x3333 Pixel) worked! This are the same images as before, we just made them smaller with ACDSee Professional 2019.

The very last test with 6000x4000 pixel jpgs – it didn’t work!!


The example we sent you before – “000361.jpg”: We made the images smaller to the size of 5000x3333 pixels and it worked (40 images).

Before we opened the existing project we just put the "new" images  into the existing jpeg-exports folder with 6000x4000px – it worked!

Then we tried it with bigger images, also with the existing project: 7000x4667px – it worked! (same process)

Finally we tried it with the original size: 8688x5792 – it worked!


During this test series we always opened the existing project – we didn’t start a new project – and it worked. Days ago when we tried it with the original size images with a new project it didn’t work; also today????

With a new project and with the high resolution images we get “unknown error detected – unable to open file”.  Is there any logic for you??


Is this the result of not enough RAM?


We photograph inscriptions on paper – we need to rotate them in the correct direction for reading – if this is a problem, is it possible to rotate a finished ptm-file?


Do all these problems just occur on Windows computers?


Is it really necessary that no other programs (for example Photoshop) are open in the background? That it’s advised that no other program runs during processing the RTI file?


Additional information of our computer:

Graphic card: NVIDIA GeForce GTX 1080


What kind of fitter – HSH or PTM – is better? With which one can you get better results?



Do you have more ideas?


Thank you!!!!


Niki and Judith


Link to comment
Share on other sites

Wow!  You folks are having a very difficult time.  I'm sorry to hear it.  We mostly work on Macs in our studio - though we have worked with Windows machines in training classes, and we recently added one to our collection of computers.  

The computer you describe should be plenty powerful to build 50MP RTI files.  We also have a 5DSR for more than 3 years, and build RTIs from those images on a regular basis. 

We know about HPLabs taking down the ptmfitter - and most of the PTM pages from their website.  We've made the ptmfitter available in a dropbox - we posted that here to the FAQ forum: 


I can't really explain all the problems you are having.  One thing to check is whether you have rotated all the images in the image set.  If there is one that is portrait for example and the rest are landscape, that will cause problems with the fitters.  If you are shooting images with the camera hanging down from a tripod - or from a camera stand, then it will sometimes "auto-rotate" the images into different orientations.  We recommend turning off auto-rotate and then rotating the whole set of images at once, when needed.  


There is a discussion comparing HSH and PTM here - there are trade-offs: 


That's all I've got time for tonight.  There are other posts about the JPEG library error on Windows in the forum -  you can try searching for that.  I wish I had a better answer for you, but I'm kind of scratching my head at this point.  I'm hoping other folks will chime in.




Link to comment
Share on other sites


I'm just a fellow-user, not involved with RTI software development, but I also use Windows platform. If it would help you, if you can share some images I would be glad to try them if I get a chance at the weekend. Will send you message with my contact details if you would like me to try.



Link to comment
Share on other sites

I have regularly had problems with the standard PTM fitter on Windows for images larger than 24 megapixels; it usually crashes. For all my PTM processing, I've switched over to using the new ptmfitter from Custom Imaging, available at https://custom-imaging.co.uk/. It can handle images up to 100 megapixels in size, and as a bonus it's a lot faster than the original HP fitter. On the downside, it won't work with RTIBuilder, so you'll need to create an lp file with RTIBuilder, and then use that with the new ptmfitter in command line mode.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...