Jump to content
ken

Invalid .rti file. Internal format unknown

Recommended Posts

On Windows 10 pro computer with 16 gig ram, Intel CPU i7 processor,  .rti files made with RTI Builder do not open in RTI Viewer.

The files begin to open, but when the progress bar is about 20% finished, RTI Viewer returns an error 

"[filepath] is invalid   Internal format unknown"

Created .RTI files are not tiny,  between 50 and 100 mbytes in size.  RTI File is created without indication of error.  

Same problem on 2 different computers. 

Running as admin and running in Win7 compatibility mode does not help.

 

 

Share this post


Link to post
Share on other sites

Ken,

A few things that would help narrow this down:

  • Have you managed to build and view RTI files before (on any of these machines)?
  • Have you any older RTI files you can (still) open?
  • Is it just one set of images that causes this?
  • If you have a set of images that worked previously, can you try re-processing them and then see if you can open the RTI file?
  • You mention it is the same on multiple computers, does that mean you've done the whole process (generate then view) on each PC? If you generate on one PC is it unreadable on all three PCs?
  • Is it the same if you generate using the PTM fitter?

Dave

Share this post


Link to post
Share on other sites

Thanks Dave for feedback,

I downloaded 2 PTM files from CHI website that successfully opened in RTI viewer. 

I have no known good RTI files  that I can try (I would happily try one if I knew a link to get one).

I have tried several different sets of images, all with the same result.  I have no previous images known to work.  I am attempting to download samples from CHI site now.

Thinking that perhaps something in the process was corrupt, I started from scratch on each computer.  I used different image sets and the same image set.  

I did not try the PTM fitter.  I would have, but the CHI link to download the PTM fitter license from HP was 404.

 

 

Share this post


Link to post
Share on other sites

Ken,

Re trying a known good PTI file; I'm away from my workstation with files currently but if you haven't got this cracked by this evening I'll pop a working RTI in a dropbox folder for you tonight.

Dave

Share this post


Link to post
Share on other sites

Dave,

Thanks much.  I must jump on a plane in a few hours.  I'll keep you posted on any possible progress until then.  I'll then be out of pocket intermittently in GMT+10  for the next few days.

Ken

Share this post


Link to post
Share on other sites

After I make the jpg files and put them into the project folder, I do not name or move

Share this post


Link to post
Share on other sites

BTW, I did not carefully inspect the LP file, but it looks like I would expect at first glance.

Share this post


Link to post
Share on other sites

Dave,

I just downloaded fish fossil sample data set from CHI and created RTI file in Builder.   RTI file opened properly in Viewer.

I guess I need to look at my image files see what is different....How it is that Builder does not object, but the product builder makes from them is objectionable to Viewer.

Ken

 

Share this post


Link to post
Share on other sites

I adjusted my jpg files so they were more similar to the sample files that worked...reduced size to 20 mpixel, increased jpg compression, changed from monochrome to rgb, reduced resolution from 600 ppi to 96 ppi (just metadata, no change to image data).  After making these changes, my files worked successfully.  I don't know which, or which combination of, these parameter changes fixed the problem.

 

Share this post


Link to post
Share on other sites

I'm guessing the issue is the size of the RTIs.  You might be able to open them on a beefier computer.  Though, in general we have successfully opened files made from a 50MP camera and full quality Jpegs on a machine with 16GB RAM.  The RTiViewer will try to open large files, and may fail if it can't open them.  Usually it fails without issuing an error - so I'm surprised by the internal filepath error.  I haven't seen that before. 

Thanks Dave for jumping in on this one!

Carla

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×