Jump to content
geier1

Not able to import images.

Recommended Posts

Hello everyone, I have an issue, let me explain a little about my project, I have high quality 3d historical scan data and have rendered about 50 images of the object, all with different sources of light. I have also done the same thing with a black sphere. My plan was do create a project using the black ball and then using that .lp file to import my object images. My issue is after i've converted my rendered images to DNG, then back into JPG, I am not able to import the picture. I was trying to select multiple images but it would not let me do that. I have also tried updating Java. Any Help? It would be very helpfull.

 
 

Share this post


Link to post
Share on other sites

Couple of quick suggestions:

 

1. Make sure there are no spaces in your file paths.

2. Make sure the pictures have a lower-case "jpg" extension, not "JPG"

Share this post


Link to post
Share on other sites

One more thing to check is whether there are spaces anywhere in the file path - not just the filename.  You can't use spaces.  That means that on a Windows system, you can't use the desktop because it s in a folder called "documents and settings" (with spaces)

 

I can't tell from your description if the files aren't loading into RTIBuilder at all, or whether you can't "execute" the build of the images in the last screen.

 

Please describe exactly what happens, what screen you are on, and whether you get any error messages.

 

Carla

Share this post


Link to post
Share on other sites

That used to be the case, but the Desktop is no longer in "Documents and Settings"; it's now in Users\<yourusername>\Desktop.

  • Like 1

Share this post


Link to post
Share on other sites

Thanks!  Good to know. I haven't worked on a Windows machine in a while.  It's still important to note that you can't have spaces anywhere in the full path to your files, not just your image file names.  A quick way to look at that, if you get errors is to open the .lp file which is in the Assembly-files folder.  You can see the full path being used, and look for spaces or special characters.

 

Carla

Share this post


Link to post
Share on other sites

One more note - I just reread this, and I think that the idea of "importing" the files is the key one.  The RTIBuilder assumes a specific file structure.  Your images MUST be in a folder called "jpeg-exports"  Then in RTIBuilder, you give the folder containing that folder, and it will load the files.  This is described in the documentation on page 9 and again on page 12.  You can get the Guide to highlight image processing here:

http://culturalheritageimaging.org/What_We_Offer/Downloads/Process/index.html

 

Also note that if you want to use a pre-determined light position file - you should use the "dome LP file" option in the first screen (PTM OR HSH as you wish)

 

Carla

Share this post


Link to post
Share on other sites

Don't use the advanced options with HSH.  They shouldn't have been put in the interface.  You can choose between 2nd order and 3rd order.  The other options won't work.

 

Carla

Share this post


Link to post
Share on other sites

I am having the same problem, not being able to export images.I  created a new project, and trying to import my folder of jpeg-exports. I have no spaces between the words in the file names and I when I go to choose the folder I get the message" The j-peg exports folder is missing in your project directory" ? why am I getting this message,Thank You? working on a MAC

 

Today I got it working !! Stored image folder on Mac's Hard drive instead of an external hard drive.

Share this post


Link to post
Share on other sites

Sorry to be late in responding - the issue when you see the message "The jpeg-exports folder is missing in your project directory" is that you didn't give RTIBuilder the correct folder.  When starting a new project, it is looking for a project level folder, that includes a jpeg-exports folder where the images are to be found.  The folder MUST have that name, and you have to give it a folder one level up from that.  This is all documented in the user guide.

 

Carla

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×