Jump to content
Ansley

Error Message with RTI Viewer

Recommended Posts

I was able to process a batch of images with the HSH method. When I open the finished-files, I am getting the following error message when I try opening in the RTI Viewer:

 

"The exception unknown software exception (0xc0000417) occurred in the application at location 0x785500be."

 

Any thoughts?

 

I am able to open and view a batch of images someone else processed with the PTM method.

Share this post


Link to post
Share on other sites

Hi Ansley,

 

A couple of thoughts:

 

1.  When creating an HSH based RTI there are 3 options for how the algorithm is applied and what information is stored - 1st order, 2nd order and 3rd order.  We know that the 1st order HSH will not produce a usable file.  So, if the HSH was created using 1st order, that could be the problem.  You can reprocess your images choosing 2nd or 3rd order.  2nd order is the default.

 

Here is a quote from the User guide about the HSH options:

 

The Order determines how many variables are used to store the mathematical description of the surface normal. Order 1 uses 4 variables, order 2 uses 9 variables, and order 3 uses 16 variables.


When you use more variables, there is more high-frequency data per pixel. The higher the order, the more information is included per pixel, and the closer the approximation of the virtual illumination in the Viewer is to the actual object. The higher order, however, also increases the file size.

 

2.  We have occasionally seen a bug where on some computers the HSH program cannot correctly create an HSH file.  It seems to be specific to some computers, and not to the image set. It is very rare, and we do not have a reproducible test case for the developers to look at.  This was discussed recently in this other thread: http://forums.culturalheritageimaging.org/index.php?/topic/247-rti-file-output-problem/

 

You can check the file size of the .rti file which was created to see if this is what you are experiencing.  If this is the case, I don't have a good solution other than to try on another computer.  It would be useful for you to report back here more about your computer configuration (mac or windows, OS version, also whether the account you are running on has administrator privileges - I suspect a permissions problem in writing the file)

 

Hope one of these helps you figure it out.

 

Carla

  • Like 1

Share this post


Link to post
Share on other sites

One other note about this - when you open an RTI file (either the .ptm format or the .rti format) you are not opening a batch of images.  Rather, the batch of images was processed and then this new file is created from the processed data.  The original images are not included in the RTI nor are they available to the viewer.  They are used to calculate the data made available to the viewer.  The calculated data includes color (RGB) per pixel, and surface shape in the form of a surface normal, per pixel.  There is an explanation of surface normals on the RTI page at CHI here: http://culturalheritageimaging.org/Technologies/RTI/#how_RTI

 

Carla

Share this post


Link to post
Share on other sites

Thank you for your prompt reply.

 

I reviewed the "processed" HSH file and discovered it is too small.


I am working from a Dell desktop PC with Windows XP, version 2002. There are many user restrictions set up into the system that were put in place by our IT Department.

 

I tried re-processing at an Order 3, but it did not seem to work. I must wait for our IT Department to install the PTM plugin.


Thanks,

Ansley

Share this post


Link to post
Share on other sites

I think if you can get the ptmfitter installed (there are instructions in the Guide to Highlight Image Processing) that you will be able to make ptms successfully.  The HSHfitter program writes info to a cache file while it is calculating, then copies the contents of that file to the file system in the finished-fles folder.  If there isn't permissions to write the cache file (which is a hidden file inside the RTIBuilder installation) then it may not be able to work for you.  

 

We are working on a new version of RTiBUilder.  However, we are not changing the hshfitter program (which RTiBuilder calls) and so this problem might still be present in the new version.  We have never had a good test case for reproducing it, and I have only seen it a few times.  I will note this with the developer, and see if there is anything we can do.  My note above is a suspicion, not a hard fact, so having a reproducible test case is necessary to really figure this out.

 

I'm sorry you are having difficulties using the software.

 

Carla

Share this post


Link to post
Share on other sites

The PTM filter has been downloaded, but I am still having trouble. The plug-in was stored in the "Documents and Settings" folder. Will this create the same problems that occur when photo files are stored there?

Share this post


Link to post
Share on other sites

What problem are you having with the ptmfitter?  Do you get an error message?

 

It should be OK to have the fitter in the documents and settings folder - the problem with spaces is for the image files that will be used by the fitter. 

 

In RTiBuilder you will need to browse to where the ptmfitter is located on your hard drive.

 

Carla

Share this post


Link to post
Share on other sites

Problem fixed. The PTM plug-in was stored in some temporary location so I was unable to properly navigate to it. I had IT move the file into the PTM plugin folder within the RTI Builder folders. This solved the problem.

 

Thanks for all your assistance!

Ansley

Share this post


Link to post
Share on other sites

I have a different RTIViewer (and RTIBuilder) error message to report on this thread. Beyond taking care not to put any spaces in file paths, regardless of one's OS, I finally twigged today that some processing and viewing problems I have been having on my new Mac (MacBook Pro OS X 10.9.4.)

are to do with the fact that my University of Cologne project folder was called "Köln".

 

post-80-0-54601000-1405106794_thumb.jpg

 

So, beyond the common list of characters/symbols to avoid (e.g. %, &, $), the use of umlauts or accents (Spanish, French, German, etc.) may also cause unwanted grief! Granted, I think I am correct in recalling that this was not a problem on my previous Windows Dell. Can anyone confirm whether this is an issue with Wndows or not?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...