Jump to content

Welcome!

Sign In or Register to gain full access to our forums.

Photo

RTI failure on crop page


  • Please log in to reply
8 replies to this topic

#1 rob-cross

rob-cross

    Member

  • Members
  • 8 posts

Posted 29 August 2017 - 04:21 PM

Greetings from Tulsa,

 

After two successful RTI builder sessions, my third one has hit a snag and eight hours later, still no luck.  Every time I get to the crop page, I run the 62 images and the process gets to "Processing two: 4265 and I receive an "Unknown Error Detected" window.  My jpeg-captures folder looks fine.  Is this possibly at PTM fitter problem?  

 

I am on a Mac Pro and when I click on the PTMFitterlocation, I only see windows applications, even though PTM fitter is sitting in my Mac Applications.  Of course, my first two objects worked fine.  when I click on the failed RTI Viewer files, my Windows in Parallels opens up.  

 

Do I need to reshoot the object and start from scratch?

 

Thank you,

Rob Cross



#2 rob-cross

rob-cross

    Member

  • Members
  • 8 posts

Posted 29 August 2017 - 05:01 PM

and add-on to my original question:  I just ran the images again this time using the HSH Fitter instead.  the session failed again and this time the Error window read: "plugin.exceptions.pathundefined: color correction file not found or you don't have permission to read it."  So I am currently dead in the water.  If I do not hear from anyone soon, I will go ahead and reshoot the entire sequence of the object and start a new RTI builder session and see what happens

 

Rob



#3 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 365 posts
  • LocationSan Francisco, CA

Posted 29 August 2017 - 08:01 PM

Hi Rob -

 

First, you should not need to reshoot your images, there is something going on with the processing.  If you are using the HSHFitter, do NOT turn on the advanced options.  That's probably what caused the error with the color correction file.  You can try opening an existing project with the Highlight based (HSH fitter) option selected and go to the log file created before.  This will take you right to the last screen where you can try again to build using the hshfitter.  Make sure to use 2nd level and no advanced options the first time through.

 

For the PTMFitter, you need to download that from HP, then wherever you install it, you need to browse to it (one time) in the final screen of RTIBuilder - on the "ptmfitter path"  Once it is set up, it should remember that location and not be a problem going forward. I know this is weird because it worked for you a couple of times.  Is it possible that this path was reset?  

 

Carla



#4 rob-cross

rob-cross

    Member

  • Members
  • 8 posts

Posted 29 August 2017 - 09:39 PM

Hi Carla,

 

Just ran the jpg's from a new shoot through the HSH fitter.  Used Order #2 and did not check advanced options as you suggested.  I received the error window again.  Up in the right it says Parameters read successfully; HSH matrix: rows=4 and columns=62; number of threads: 8

 

Up in the location window it says "/Applications/RTIbuilder-v2.0.2.app/Contents/Resources/Java/Fitters/HSHfitter/hshfitter"

I usually use the PTM fitter, so I will go back and try that one again next

 

thank you, Rob



#5 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 365 posts
  • LocationSan Francisco, CA

Posted 29 August 2017 - 09:52 PM

Just to clarify you received the same error: "plugin.exceptions.pathundefined: color correction file not found or you don't have permission to read it." and this appears in a popup window?

 

In normal operation RTIBuilder has to create a cropped file for each image, and then it hands off the images to the fitter.  The Fitters are separate programs, and they don't provide much feedback.  RTIBuilder reports the feedback from the fitters in the information window (where the running list of cropping images was)  It's a bit confusing, and sometimes folks think that the system is finished when RTIBuilder hands over the operation to the fitter.  If you just received the "Parameters read successfully; HSH matrix: rows=4 and columns=62; number of threads: 8" in the information window, then everything is good, it just needs time to calculate your file.  Let it run, and then you should get the "fitting complete" popup.  If however you had an actual error popup, then I'm wrong.  I just wasn't sure from what you wrote here.



#6 rob-cross

rob-cross

    Member

  • Members
  • 8 posts

Posted 29 August 2017 - 10:11 PM

yes, I received a pop-up error message - that is what's so frustrating.  I have the black ceramic balls in the photo, but this should not matter.  they were in the two sessions that worked just fine yesterday.  that is what's so strange - I completed two sessions yesterday and everything worked fine and then - boom - twelve hours and nothing has worked on the third session.  I looked at the PTM folders in my Applications folder and they match the current downloads from the HP site.  but the file is a Windows file, not a Mac file.  I assume that is okay since I downloaded the Mac version



#7 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 365 posts
  • LocationSan Francisco, CA

Posted 29 August 2017 - 10:27 PM

I want to make sure that you are receiving the same error message about the color correction file, and not a different error?  If you get "unknown error" in the popup window, the culprit is likely that you have spaces somewhere in your filenames or path names.

 

There are Windows and Mac versions of the ptmfitter.  The Mac one runs on a Mac - it isn't a windows file.  It does not have an extension, and is just called ptmfitter.  I work primarily on Macs.

 

The fact that it worked then stopped working is very curious, and unusual. I don't think it has anything to do with your image sets, it is something in the RTIBuilder configuration. If the issue is that you are still getting the color correction file error, then you could try to delete RTIBuilder and reinstall it from the disk image (downloaded .dmg file).  I know that isn't the most helpful suggestion, but it might do the trick.

 

Carla 



#8 rob-cross

rob-cross

    Member

  • Members
  • 8 posts

Posted 30 August 2017 - 02:41 PM

I'll go ahead and reinstall the software.  

 

just in case, here is an example of a jpg file: 9025.1679a_072.jpg.  

 

I have attached a screen shot to show you the folder structure.  you can see that the failed output show up outside the folders: spiroshellseight.xml.  

 

I have attached a second screen shot to show you the PTM area of my Applications folder.  the EXEC file is in there - this is the Mac download, but is not an exec file for Windows?  plus, it worked just fine on the first two objects, so it must be okay!

 

 

Attached Files



#9 rob-cross

rob-cross

    Member

  • Members
  • 8 posts

Posted 30 August 2017 - 03:10 PM

just ran the image sequence for the object in the newly downloaded RTI builder software.  when I got to the crop page, I was unable to find the PTMFitter Location - all that comes up are Windows folders - I am unable to access the Mac side of my Applications folder.  so, I moved the PTM Fitter to the desktop and used that location.  the program ran fine until it got to row 4416.  it always stops on row 4416.  and then the pop-up window came up and it says: "Unknown error detected!"

 

I will have to suspend the RTI photography for now - I still have seventeen objects to go and I am not sure what to do - thank you for your help!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users