Jump to content

Welcome!

Sign In or Register to gain full access to our forums.

Photo

Not able to import images.

processing 3d scan data

  • Please log in to reply
9 replies to this topic

#1 geier1

geier1

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 April 2017 - 04:49 AM

Hello everyone, I have an issue, let me explain a little about my project, I have high quality 3d historical scan data and have rendered about 50 images of the object, all with different sources of light. I have also done the same thing with a black sphere. My plan was do create a project using the black ball and then using that .lp file to import my object images. My issue is after i've converted my rendered images to DNG, then back into JPG, I am not able to import the picture. I was trying to select multiple images but it would not let me do that. I have also tried updating Java. Any Help? It would be very helpfull.

 
 


#2 leszekp

leszekp

    Advanced Member

  • Members
  • 67 posts

Posted 21 April 2017 - 07:12 PM

Couple of quick suggestions:

 

1. Make sure there are no spaces in your file paths.

2. Make sure the pictures have a lower-case "jpg" extension, not "JPG"



#3 geier1

geier1

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 23 April 2017 - 02:45 PM

Does an underscore count? for example my images are set up like this "lamp_sun.000" Otherwise they are in .jpg format



#4 leszekp

leszekp

    Advanced Member

  • Members
  • 67 posts

Posted 23 April 2017 - 10:06 PM

Underscore shouldn't be a problem.



#5 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 366 posts
  • LocationSan Francisco, CA

Posted 04 May 2017 - 08:38 PM

One more thing to check is whether there are spaces anywhere in the file path - not just the filename.  You can't use spaces.  That means that on a Windows system, you can't use the desktop because it s in a folder called "documents and settings" (with spaces)

 

I can't tell from your description if the files aren't loading into RTIBuilder at all, or whether you can't "execute" the build of the images in the last screen.

 

Please describe exactly what happens, what screen you are on, and whether you get any error messages.

 

Carla



#6 leszekp

leszekp

    Advanced Member

  • Members
  • 67 posts

Posted 05 May 2017 - 06:21 AM

That used to be the case, but the Desktop is no longer in "Documents and Settings"; it's now in Users\<yourusername>\Desktop.


  • Carla Schroer likes this

#7 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 366 posts
  • LocationSan Francisco, CA

Posted 05 May 2017 - 02:45 PM

Thanks!  Good to know. I haven't worked on a Windows machine in a while.  It's still important to note that you can't have spaces anywhere in the full path to your files, not just your image file names.  A quick way to look at that, if you get errors is to open the .lp file which is in the Assembly-files folder.  You can see the full path being used, and look for spaces or special characters.

 

Carla



#8 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 366 posts
  • LocationSan Francisco, CA

Posted 21 July 2017 - 03:20 AM

One more note - I just reread this, and I think that the idea of "importing" the files is the key one.  The RTIBuilder assumes a specific file structure.  Your images MUST be in a folder called "jpeg-exports"  Then in RTIBuilder, you give the folder containing that folder, and it will load the files.  This is described in the documentation on page 9 and again on page 12.  You can get the Guide to highlight image processing here:

http://culturalherit...cess/index.html

 

Also note that if you want to use a pre-determined light position file - you should use the "dome LP file" option in the first screen (PTM OR HSH as you wish)

 

Carla



#9 geier1

geier1

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 21 July 2017 - 02:09 PM

Ok thanks for the help everyone. I am running into another problem now... I am not able to click execute once I have created a defined highlighted area. Help anyone?https://ibb.co/bUs1H5



#10 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 366 posts
  • LocationSan Francisco, CA

Posted 22 July 2017 - 02:29 AM

Don't use the advanced options with HSH.  They shouldn't have been put in the interface.  You can choose between 2nd order and 3rd order.  The other options won't work.

 

Carla







Also tagged with one or more of these keywords: processing, 3d scan data

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users