Jump to content

Welcome!

Sign In or Register to gain full access to our forums.

Photo

Problems processing PTM vs HSH?


  • Please log in to reply
23 replies to this topic

#21 Marta Diaz-Guardamino

Marta Diaz-Guardamino

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 10 September 2015 - 08:24 PM

Hi Carla and all, 

 

I am having the same problem Ansley reported in March 2014 with the batches I have been processing during the last months. I am not being able to process them with the PTM fitter while the HSH works perfectly well. I have checked and there are no spaces in paths, .jpg is always in low case and I have tried in different PCs (with Windows 7 and 8). The only thing I can recall that I have changed is the camera I work with (now a Nikon D800e) but I cannot see how that could be a problem.

 

Any help would be very much appreciated. Just in case this helps here I attach the xml file of the last batch that worked with the HSH fitter and that has failed to process with the PTM fitter.

 

Many thanks in advance.

 

Marta

 

 

 

Attached Files



#22 Carla Schroer

Carla Schroer

    Advanced Member

  • Administrators
  • 366 posts
  • LocationSan Francisco, CA

Posted 10 September 2015 - 10:36 PM

Dear Marta -

 

I took a look at your .xml file.  The error is returning from the ptmfitter.  RTIBuilder manages your images, light position file, etc, then it calls a separate piece of software (called a fitter) to do the calculations to make the final file.  the HSHfitter is shipped with RTIBuilder, but due to license restrictions, we can't ship the ptmfitter.  So, you have to get it from HPLabs and install it yourself and then tell RTIBuilder where you installed it.

 

RTIBuilder is looking for the ptmfitter here: \\soton.ac.uk\ude\personalfiles\users\mdgu1v11\mydesktop\PTMfitter\PTMfitter.exe

 

Can you double-check that the ptmfitter is in this location, and is set with permission to execute?  Have you ever been able to build ptms on this computer, or only HSH?  There isn't really an installation program for the ptmfitter, you should just need to put it anywhere on your system where you have execute permissions and it should work.

 

The other potential issue, is that the Nikon D800 is a 36MP camera, and you may not have enough memory to process files that large.  You could try creating a set of jpegs that are smaller  (try about 20MP) and see if it will work.  The ptmfitter can successfully build large image sets, but it does require more memory on your computer.  Unfortunately, the ptmfitter software is a command line tool and doesn't issue a lot of useful error messages, so RTIBuilder has no information about why it failed.

 

Hopefully this experiment will help figure it out.  I'll note that the ptmfitter was written in 2001 when a 3MP camera was a marvel.  It's kind of amazing it has stood up this well to ever increasing image sizes.  I know people have successfully built pmts from images that large, but you may need to have a machine with more RAM (how much RAM do you have?)

 

Carla


  • caseycameron likes this

#23 Adriene Tacla

Adriene Tacla

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 November 2017 - 11:07 PM

Hi,

 

I have been using RTI for my work since January and had no problems with the previous version of RTIbuilder on a PC with Win 7. However, now on a new PC with Win 10, I am getting all kinds of problems, even after updating java and reinstalling the software. It does not process either in HSH or in PTM. When using HSH, it has an error that says: Improper call to JPEG library in state 200.  Whereas, when attempting to process PTM, I get a message of Unknown error with the following output information:

 

"Polynomial Texture Map (PTM) Fitter

Copyright Hewlett-Packard Company 2001. All rights reserved.
See included readme and license files.
 
C:\RTIbuilder_v2_0_2\Fitters\PTMfitter.exe usage:
  -i filename
    Full filename for lp file specifing input files and light positions. 
 
  -PTM <path>/<file.ptm>
  -o <path>/<file.ptm>
     Output file name.
 
  -RGB | -LRGB
  -f format (format either 0 for RGB or 1 for LRGB
     Create either an RGB or LRGB PTM. (Default: LRGB)
 
  -BIVARIATE | -UNIVARIATE
  -b basis  (basis either 0 for biquadratic or 1 for univariate
     Calculate a least squares fit of one independent variable:  -UNIVARIATE
                                   or two independent variables: -BIVARIATE
     (Default: BIVARIATE)
 
  -version
    Prints software version
 
  -h
     List command line options"
 
Does anyone have any suggestions on how to solve this?
 
Thanks!
Adriene


#24 leszekp

leszekp

    Advanced Member

  • Members
  • 67 posts

Posted 16 November 2017 - 04:23 AM

This is the kind of error that pops up if the proper input variables have not been passed to the PTMfitter program. You might try running RTIBuilder as an admin (right-click on the program icon, and choose Run as Administrator); this has fixed similar problems for me.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users